▄▄             ▄▄▄  ▄▄▄ Power
█  █ ▄▄▄▄ ▄▄▄▄▄ █  █ █  █
█▄▄█ █▄▄▄ █ █ █ █▀▀▄ █▀▀▄
█  █ ▄▄▄█ █ █ █ █▄▄▀ █▄▄▀

Login
Register
/ ad amd64 api asm asmbb best bugs chat common debian deck design dll docker email embed fast feature files fossil fresh.ide friendly gamedev heap help hiawatha incredible interop learning libfresh limit links linux meme meta.http-equiv money mysql neo nginx numbers orly os outage pass password programmers programming proile resources safety script.alert.xss secret seo skins sodom source sourcecode subforum support tags test type work xss игнат котики парола русский тест уеб.програмиране хабр.наполеон
Categories Thread list

Help installing asmbb

Please help me getting asmBB to install. I'm not very technically proficient, but I hope you will be willing to help me anyway.

I got a small shared hosting plan with FastCGI to try asmBB. I did a quick phpinfo check to confirm FastCGI is good to go. This is what I did:

1. Uploaded asmbb.tar.gz and unpack.tar.gz to the document root (public_html) directory.

2. Extracted unpack.tar.gz using cPanel, and then moved the files in the newly created "unpack" directory one directory up into the document root directory.

3. Navigated to mywebsite.com/unpack.sh

All I get is a "Not found." The unpack script seems to have run fine, since there are plenty of new files in the directory. But I can't get to asmBB's setup script to run.

Did I skip something obvious here? I've read through all the installation instructions but I don't see what I could have missed.

user65

Please help me getting asmBB to install. I'm not very technically proficient, but I hope you will be willing to help me anyway.

I got a small shared hosting plan with FastCGI to try asmBB. I did a quick phpinfo check to confirm FastCGI is good to go. This is what I did:

1. Uploaded asmbb.tar.gz and unpack.tar.gz to the document root (public_html) directory.

2. Extracted unpack.tar.gz using cPanel, and then moved the files in the newly created "unpack" directory one directory up into the document root directory.

3. Navigated to mywebsite.com/unpack.sh

All I get is a "Not found." The unpack script seems to have run fine, since there are plenty of new files in the directory. But I can't get to asmBB's setup script to run.

Did I skip something obvious here? I've read through all the installation instructions but I don't see what I could have missed.

If I understood correctly, we are talking about shared hosting with Apache server. Right?

Everything you have done seems to be OK. The installation should work this way. Check the content of the result .htaccess file in your document root directory. It should contains the proper path to engine executable file.

Do you have a file board.sqlite in the root directory? If this file exists, the engine was started at least once by the web server.

Actually it must contains only 3 lines: Options ExecCGI FcgidWrapper "_FULL_PATH_TO_DOCUMENT_ROOT_HERE_/engine" virtual SetHandler fcgid-script

Check whether the placeholder _FULL_PATH_TO_DOCUMENT_ROOT_HERE_ is properly replaced with the right path to the document root. Also, double check the permissions for the files engine, ld-musl-i386.so and libsqlite.so - they must be 755.

Check the server error messages when you try to open the main page - in cpanel there is a page that display the latest errors.

It is possible that the FastCGI is actually disabled. You should ask the hosting provider support for that and possibly they can enable it. Ask about the apache module mod_fcgid.

Notice, that there is another FastCGI Apache module - mod_fastcgi. If so, you will need to make some changes in .htaccess last line. But I am not sure what exactly, because have no experience with mod_fastcgi.

The error "404 Not found" you get make me think the server actually search some file like index.html, etc. But this means that the server does not conform with the .htaccess file or the .htaccess file is somehow broken.

BTW: which hosting provider you are using and what plan?

johnfound

If I understood correctly, we are talking about shared hosting with Apache server. Right?

Everything you have done seems to be OK. The installation should work this way. Check the content of the result .htaccess file in your document root directory. It should contains the proper path to engine executable file.

Do you have a file board.sqlite in the root directory? If this file exists, the engine was started at least once by the web server.

Actually it must contains only 3 lines: Options ExecCGI FcgidWrapper "_FULL_PATH_TO_DOCUMENT_ROOT_HERE_/engine" virtual SetHandler fcgid-script

Check whether the placeholder _FULL_PATH_TO_DOCUMENT_ROOT_HERE_ is properly replaced with the right path to the document root. Also, double check the permissions for the files engine, ld-musl-i386.so and libsqlite.so - they must be 755.

Check the server error messages when you try to open the main page - in cpanel there is a page that display the latest errors.

It is possible that the FastCGI is actually disabled. You should ask the hosting provider support for that and possibly they can enable it. Ask about the apache module mod_fcgid.

Notice, that there is another FastCGI Apache module - mod_fastcgi. If so, you will need to make some changes in .htaccess last line. But I am not sure what exactly, because have no experience with mod_fastcgi.

The error "404 Not found" you get make me think the server actually search some file like index.html, etc. But this means that the server does not conform with the .htaccess file or the .htaccess file is somehow broken.

John, thanks so much for taking the time to help me with this. It is indeed an apache server (2.4.34), using a starter plan from ForwardWeb. ForwardWeb doesn't use FastCGI by default, but will enable it if you submit a ticket, which I did immediately after buying service from them. phpinfo says the Server API is "FPM/FastCGI." It might be that "mod_fastcgi" was enabled instead of "mod_fcgi"; I'll submit a ticket inquiring about it.

I think you are right that the .htaccess file is not working. There is no board.sqlite file, so engine has never run. If I place an index.html file in the root, it will go there right away.

Permissions for engine and the .so files are correct; and the path in the .htaccess file is correct as well. cPanel's "Last 300 Error Log" does not display anything, and I can't figure out where error logs are being stored. I'll submit a ticket about that too.

Let me know if this information gives you any more ideas, and thanks again for your help!

user65

It might be that "mod_fastcgi" was enabled instead of "mod_fcgi"; I'll submit a ticket inquiring about it.

I never worked with "mod_fastcgi", but according to some information, it could be even better, because of better implementation of FastCGI protocol.

But the problem is that it probably has different parameters. Before submitting ticket try to replace in .htaccess: fcgid-script with fastcgi-script and FcgidWrapper with FastCgiWrapper to see what will happen.

I will check some documents and will post here if there is something new.

After some more reading, it seems that mod_fastcgi allows configuration only in the server config files, but not in the .htaccess file.

This way, I simply don't know how it can be made to work with AsmBB. The only way is if the support team configures it for you. The users of the shared hosting simply does not have access to the server config files.

But, anyway, I simply have no any experience with this module and can be wrong. You should better discuss the problem with your support team.

I will try to describe what are AsmBB recuirements. They are only two:

1. Someone must to start the engine file. In mod_fcgid this is done by the FcgidWrapper PATH_TO_EXECUTABLE directive in the .htaccess.

2. All requests for the domain must be passed to the AsmBB by the Appache server. This is done by the option virtual at the end of the FcgidWrapper directive in the .htaccess file.

Well, this looks like the problem. I got this response to my query about why errors weren't being logged:

I cleaned out your .htaccess file as there were some conflicts. You will now see the errors within your cPanel. Here is a back-up of what you had in your .htaccess file:

Options ExecCGI

FcgidWrapper home***/public_html/engine virtual

SetHandler fcgid-script

Also, please note that the above would would be global server settings that you can not set within .htaccess from any shared web hosting account.

The new .htaccess is just comments saying not to edit it. It looks like this: # php -- BEGIN cPanel-generated handler, do not edit # NOTE this account's php is controlled via FPM and the vhost, this is a place holder. # Do not edit. This next line is to support the cPanel php wrapper (php_cli). # AddType application/x-httpd-ea-php56 .php .phtml # php -- END cPanel-generated handler, do not edit

So. Basically, I can't set my own .htaccess file. I doubt there is any workaround for this, but do you have any ideas?

If not, could you possibly recommend a shared hosting service that would provide me the kind of access I would need to get asmBB to function?

Thanks again for your help.

user65

So. Basically, I can't set my own .htaccess file. I doubt there is any workaround for this, but do you have any ideas?

You definitely can. That is why .htaccess files exists - to be used for local configurations by the user.

Anyway, you can try one more time to ask about mod_fcgid activation. It can be controlled from the .htaccess file. At least enough to run AsmBB.

I can't suggest specific hosting provider, simply because now I am using small vps. My previous provider was "Super Hosting" and their servers allow running AsmBB with one exception - the chat will not work, because of a bug in the Apache HTTP2 module.

Anyway, the VPS now are pretty cheap, that is why I migrated on a small VPS ($6 per month), where I can use nginx server and whatever services and settings I need.

Although, the big disadvantage of VPS is that you need to setup your own email services (if you need them, of course) and managing email servers is pretty tedious task. They are fragile and need permanent supervision.

Help installing asmbb

AsmBB v2.4 (check-in: 7bb3292ed42db7ca); SQLite v3.25.3 (check-in: 89e099fbe5e13c33);

©2016..2018 John Found; Licensed under EUPL.
Powered by Assembly language
Created with Fresh IDE

Icons are made by Egor Rumyantsev, vaadin and icomoon from www.flaticon.com