AsmBB

Power
Login Register
Threads Categories Chat

user post is not found if username has dot

ganuonglachanh (ツ)

Hi johnfound

If username has a . then posts of this user will not found, in URL like this:

https://board.asm32.info/!search/?u=a.lamanda

May be it in the SQL, please check it.

Thank you very much!

johnfound (ツ)
ganuonglachanh

Hi johnfound

If username has a . then posts of this user will not found, in URL like this:

https://board.asm32.info/!search/?u=a.lamanda

May be it in the SQL, please check it.

Thank you very much!

Thanks for the report! I will check and fix it.

johnfound (ツ)
johnfound
ganuonglachanh

Hi johnfound

If username has a . then posts of this user will not found, in URL like this:

https://board.asm32.info/!search/?u=a.lamanda

May be it in the SQL, please check it.

Thank you very much!

Thanks for the report! I will check and fix it.

Well it is fixed in the following commit: 8911d2d810d33d21

The binary package with v2.8 will be released soon. Right now the final checks and polishing is in progress.

This way, if you know about more bugs it is the right time for reporting. ;-)

ganuonglachanh (ツ)
johnfound (ツ)
ganuonglachanh

Thanks johnfound

It's seem fix in latest checkin, please take a look at some bug reported in the past:

https://board.asm32.info/js-load-event-error-in-console-repeatly.283/

https://board.asm32.info/asmbb-engine-high-cpu-usage-with-stress-test.282/

Thank you very much rofl

The first bug (with the JS reconnect) is already fixed in the current trunk.

As for the second bug - I have made a lot of tests with provided parameters, but never was able to confirm it. Can you provide some detailed and more reproducible setup...

©2016..2020 John Found; Licensed under EUPL; AsmBB v2.8 (check-in: 6d0d9d4bca1af5dd); SQLite v3.31.1 (check-in: 3bfa9cc97da10598); Powered by Assembly language; Created with Fresh IDE;