AsmBB

Power
Login Register

Can't compile

#15695 (ツ) vhanla
Last edited: 26.11.2018 by johnfound, read: 1863 times

I don't know why but it doesn't compile, it throws error

FreshIde AsmBB

I followed all instructions, using latest Freshlib, Flatassembler and AsmBB source code.

It just shows "illegal instruction" on each "tpl_func" macro. Why is that?

BTW: FreshIDE was successfully compiled. I also tried via command line, same error happens.

#15696 (ツ) johnfound
Created 26.11.2018, read: 1858 times
vhanla

I don't know why but it doesn't compile, it throws error

FreshIde AsmBB https://i.imgur.com/dAK1Mvs.png

I followed all instructions, using latest Freshlib, Flatassembler and AsmBB source code.

It just shows "illegal instruction" on each "tpl_func" macro. Why is that?

BTW: FreshIDE was successfully compiled. I also tried via command line, same error happens.

Hm, interesting. Did you properly checked-out the latest FreshLibDev branch? Also, you should actually set the path to the FreshLibDev directory in the Options|IDE options|Aliases as a lib alias.

I know that this all is pretty annoying, but AsmBB is one of the projects that work as a test case for the FreshLib library, so the library is changed often with the project.

P.S. The links should be used not on the first character of the line. Simply insert one space in order to display them as in my quote. (this should be fixed in the JS formatting code, but...)

#15697 (ツ) vhanla
Created 26.11.2018, read: 1851 times
johnfound

Did you properly checked-out the latest FreshLibDev branch?

Is this one at https://fresh.flatassembler.net/fossil/repo/fresh/index or a different repository?, I'm new to fossil, I just run "fossil open ..." using that fossil file.

johnfound

Also, you should actually set the path to the FreshLibDev directory in the Options|IDE options|Aliases as a lib alias

I set "lib" path to "freshlib" directory inside Fresh's cloned repository.

Nevermind. Since I'm new to fossil, I was using the wrong branch "trunk", so I switched to "FreshLibDev" one (fossil update FreshLibDev), now it works. Thank you.

#15698 (ツ) johnfound
Last edited: 26.11.2018 by johnfound, read: 1847 times
vhanla
johnfound

Did you properly checked-out the latest FreshLibDev branch?

Is this one at https://fresh.flatassembler.net/fossil/repo/fresh/index or a different repository?, I'm new to fossil, I just run "fossil open ..." using that fossil file.

johnfound

Also, you should actually set the path to the FreshLibDev directory in the Options|IDE options|Aliases as a lib alias

I set "lib" path to "freshlib" directory inside Fresh's cloned repository.

Nevermind. Since I'm new to fossil, I was using the wrong branch "trunk", so I switched to "FreshLibDev" one (fossil update FreshLibDev), now it works. Thank you.

No, the Fresh IDE trunk branch does not contains the latest version of FreshLib. It is updated, but not so frequently as needed for AsmBB compilation.

Simply create one new working directory and checkout the "FreshLibDev" branch:

mkdir /PROJECTS/FreshLibDev
cd /PROJECTS/FreshLibDev
fossil open /REPOSITORIES/fresh.fossil FreshLibDev

Here PROJECTS is the path to your working directories/projects. REPOSITORIES is the path to the directory where you cloned the Fresh IDE repository (the fresh.fossil file or whatever you named it). Relative paths should work as well.

Then change the lib alias to point to /PROJECTS/FreshLibDev/freshlib

No need to clone the repository again. When you need to update the checkout (working directory) with the latest changes simply execute fossil update inside the directory.

AsmBB v2.9 (check-in: 6d407831308ba556); SQLite v3.31.1 (check-in: 3bfa9cc97da10598);
©2016..2020 John Found; Licensed under EUPL. Powered by Assembly language Created with Fresh IDE