▄▄             ▄▄▄  ▄▄▄ Power
█  █ ▄▄▄▄ ▄▄▄▄▄ █  █ █  █
█▄▄█ █▄▄▄ █ █ █ █▀▀▄ █▀▀▄
█  █ ▄▄▄█ █ █ █ █▄▄▀ █▄▄▀

Login
Register
/ / aa about.it ad amd64 and.who api asm asmbb asmbb.features authentication bbcode best bugs cares chat common debian deck design dll docker email embed fast feature files fossil fresh.ide friendly gamedev heap help hiawatha i18n incredible interop learning libfresh limit links linux mailing.list meme meta.http-equiv minimag money mysql neo nginx numbers orly os outage pass password post-by-email programmers programming proile read-by-email resources safety script.alert.xss secret seo skins sodom source sourcecode subdirectory subforum support tags test test123 type very.ugly work xss игнат котики парола русский тест уеб.програмиране хабр.наполеон
Categories Threads

Running in a subdirectory

I just tested out the forum with nginx in a subdirectory of my server (because I don't have a subdomain available right now) and I noticed this doesn't work correctly. The form target for the admin registration for is set to

/!adminrulez

for example, which results in a 404 for me (it should be

/forum/!adminrulez

for me). Support for this would be pretty easy to add I think (just add an additional config option and associated template variable) and it would be a common use case IMO. What do you think?

Well, AsmBB is designed to work in a subdomain. I have never tried to run it in a subdirectory. The path for the templates is the easiest part. Actually in order to run it in a subdirectory will need an additional prefix to be added to every URI in the engine, which might be not so easy to be done.

When I have time I will research this issue in depth.

AsmBB v2.5 (check-in: 97ceb202897848d8); SQLite v3.27.2 (check-in: bd49a8271d650fa8);

©2016..2018 John Found; Licensed under EUPL.
Powered by Assembly language
Created with Fresh IDE

Icons are made by Egor Rumyantsev, vaadin and icomoon from www.flaticon.com